PHP is one of the most widely used general-purpose scripting languages. It is rather popular as it is free software, which can be used to develop responsive sites like social networks, e-shops or school websites instead of static HTML websites. A PHP module should be enabled on the web server where a PHP-powered site is hosted so that its PHP code can be ‘deciphered’. Because there aren’t any license fees for this type of module and the language itself provides incalculable possibilities for the Internet applications that you create, there’re 100s of millions of PHP sites. Additionally, there are an immense number of PHP scripts, which you can use for your websites without needing to have any programming skills. As there are a couple of versions of PHP, you have to confirm that the exact same version that you used while setting up your site is installed on the server too.

PHP 4, PHP 5 and PHP 7 Support in Shared Hosting

With our shared hosting service, you’ll be able to select which PHP version will be enabled for your account, as different versions are supported on our servers. With just one click of the mouse, you will be able to switch between PHP 4, 5, 7 and every time a new version is released in the future, we will include it in the Hepsia hosting Control Panel without removing the earlier ones. In this way, you’ll be able to host all the sites that you’ve created over the years. In contrast to a lot of other providers, we will not compel you to update such websites, as a script may be out of date, but this does not mean that it is insecure as you may have performed modifications to its code to plug security loopholes. For your convenience’s sake, you’ll even be able to choose a different PHP version for each site that you host in your account.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Servers

We are firm in our belief that several years spent developing a site shouldn’t be in vain, so in case you purchase a semi-dedicated server from us, you’ll be able to run any script, regardless of whether it’s new or old. In contrast with lots of hosting companies, we support a number of different PHP versions on our cutting-edge cloud platform – 4, 5 and 7. You will not only be able to enable the version that you need through your Hepsia Control Panel, but you will also have the opportunity to select a different version for each website. This can be done merely by adding an .htaccess file to the root directory of the given site. You can change the version not only for a single website, but also for the whole account and the change will be applied in just several minutes. With our hosting services, you can be sure that you won’t ever run into any website compatibility difficulties.